Please?

I have a strange problem and am wondering if anyone has encountered it themselves (thus knowing a solution).

I used an external while working on my husbands desktop. Now I have my own laptop and hook the external up to that and access my scrap stash. Everything works perfectly- except when it doesn't.

SOME (not all) files don't open in Photoshop. These same files worked fine when I was using the external on the desktop. Now, when I try to open them in Photoshop on my laptop I get this error:

Could not complete your request because the file is locked, you do not have necessary access permissions, or another program is using the file. Use the 'Properties' command in the Windows Explorer to unlock the file

I tried a few different things and nothing works (I admit I have no clue what I'm doing either).

All I want to do is open my files but it won't let me- saying they are locked, I can't even view any images/previews within the folder either.

:'(

Does anyone have any idea what is going on, why and possibly how I may rectify it?

Please and thanks!