View Full Version : Help Please- locked files make me sad.

10-15-2012, 08:17 PM

I have a strange problem and am wondering if anyone has encountered it themselves (thus knowing a solution).

I used an external while working on my husbands desktop. Now I have my own laptop and hook the external up to that and access my scrap stash. Everything works perfectly- except when it doesn't.

SOME (not all) files don't open in Photoshop. These same files worked fine when I was using the external on the desktop. Now, when I try to open them in Photoshop on my laptop I get this error:

Could not complete your request because the file is locked, you do not have necessary access permissions, or another program is using the file. Use the 'Properties' command in the Windows Explorer to unlock the file

I tried a few different things and nothing works (I admit I have no clue what I'm doing either).

All I want to do is open my files but it won't let me- saying they are locked, I can't even view any images/previews within the folder either.


Does anyone have any idea what is going on, why and possibly how I may rectify it?

Please and thanks!

10-15-2012, 08:23 PM
It's somehow locked, saying I need permission to use it from this (odd numbered) user? I don't quite understand what is going on and it's becoming increasingly frustrating.

10-15-2012, 08:39 PM
Do you have yourself set as administrator?

10-15-2012, 09:37 PM
Is it set for "read only" right click...choose properties...and if read only is checked, uncheck it in the program or service you are running it on...just guessing here, I don't know if that's it

10-15-2012, 09:59 PM
Could very well be one computer is a different version from the other, thus some files saved in different formats, THUS unable to open. Could be. Could also be the external changed as a result of the 'move'.

Is your laptop new and are both computers up to date? Very important when connecting EHD's.

10-16-2012, 05:21 PM
I'm at work right now. But I've had it happen to me, and somewhere...I wrote the steps down.
Mine are for windows 7. It is in the 'read only' as Tony said above, but I know there were more clicks I had to do.
It went into ...dang...
[from brain...]
advanced > security [I think] and then had to add something.
[darn -old brain].
I will look this evening.

10-16-2012, 05:35 PM
Thank you everyone, and I'll wait for your updated post Michi!

10-16-2012, 05:39 PM
Hoping it'll work our quick April!

10-16-2012, 10:06 PM
I'm back.
it's long, but not impossible.
1. right click the folder> properties- be sure both 'read only' and 'hidden' are unchecked
2. click advanced > place check mark in the 2nd box that reads "allow files in this folder to have contents indexed in addition to file properties > ok
3. on the top tab >security ...> edit > add > and type in the box the word Everyone
4. click OK...it will return to the previous dialog box with the security tab.
5. click Apply > Click OK [and cross your fingers.

I just did one [to test my brain out with it in front of me and it worked.
Let me know.

10-16-2012, 10:09 PM
Yep, you were right...more clicks :) Good job with this! Good luck April, I hope this works for you

10-16-2012, 11:00 PM
It didn't work :( :(
I'm going to have my super computer Husband check it out too later tonight.

10-16-2012, 11:33 PM
You probably have, but just in case ...have you tried restarting your computer?

10-16-2012, 11:40 PM
Yup. :(

You probably have, but just in case ...have you tried restarting your computer?

10-16-2012, 11:56 PM
Are you using an older version of Photoshop with a newer OS, like Windows 7?

When I was trying to run Photoshop CS on Windows 7, I had some weird issues.

10-17-2012, 12:54 AM
Which OS--- and let me look again, in case I typed wrong.

10-17-2012, 01:07 AM
Windows 7.

10-17-2012, 01:13 AM
:( I had that happen with my EHD on my mac. I think I had to move everything back and forth from my HD and EHD to get them to unlock.

10-17-2012, 01:25 AM
:( I had that happen with my EHD on my mac. I think I had to move everything back and forth from my HD and EHD to get them to unlock.

Ahhh...could be, as my situation occurred when I went from xp to win 7 , and did a big save on the EHD first and then placed all onto the hard drives. I did not think of that Meg. Thanks.

10-17-2012, 01:48 AM
I can't even move the file from EHD to HD... no joke- it's so freaking weird. I've given up on it for right now. Luckily, no GS stuffs is locked (that I can see!).

10-17-2012, 02:07 AM
that stinks!! I was giong to suggest trying the unchecking of the "read-only" box as well - but I see that didnt work! Not sure what else to tell you - GOOD LUCK :S Grrr! Frustrating technology sometimes ;)

10-17-2012, 02:36 AM
Ok, cannot move files from EHD... Hmmm let me think some more. It has to be ,somewhere ... In shared files ...or admin rights for them.
What happens if you double click on a locked folder?

I do enjoy a challenge.

10-17-2012, 08:59 AM
From what I am reading could very well be your ehd needs to be re-formatted. As I wrote, a change can do weird things.

10-17-2012, 01:08 PM
See if this helps

10-17-2012, 03:10 PM
April if your EHD is a Seagate -- call them. They have FANTASTIC customer support -- and your call goes directly to a call center in America ;)

10-31-2012, 06:58 PM
April that's what mine was doing before it died.

11-07-2012, 09:50 PM
April that's what mine was doing before it died.

Same here. It's not a good sign. Sorry. :(